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Using Microsoft Excel

Introduction

This handout briefly outlines most of the basic uses and functions of Excel that we will be using in this course.
Although Excel may be used for performing statistical tests, we will use it primarily to perform simple
transformations of data and compute data summaries.  We will also use it to arrange and sort the data for graphing
in Excel.

Excel basics

Cell addresses:

Each cell has an "address" which consists of a letter followed by a number.  The letter designates which
column the cell is in, and the number designates which row.  The column and row labels may be found at the
top and left-hand sides of the worksheet, respectively.  Note the location of cell "A4" in the example above.

Window size button

In the upper right-hand corner of the spreadsheet, you will see a small box.  Clicking here will enlarge the
window to the full size of the screen.  Clicking in this box again will reduce the window back to its former
size.  This is especially useful if the window is too big for the screen.

Help

To obtain help about anything you see on the screen, click on the box in the upper right corner containing a
question mark (see figure above).

Moving around in the spreadsheet

At the bottom and right-hand sides of the spreadsheet window, you will find the scrolling arrows, bars, and
boxes.  Clicking and holding the mouse button on the arrows will scroll the spreadsheet one row or column at
a time in the direction of the arrow.  The position of the scroll box shows what part of your spreadsheet the
screen is currently showing.  For example, if you are near the top of your spreadsheet, the box will be near the
top of the screen. By clicking on this box and dragging it up or down, you can jump quickly to other parts of
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your spreadsheet.  If you drag the box half-way down the scroll bar and then release the mouse button, the
screen will change to show a section of your spreadsheet that's about in the middle.  Clicking once in the
scroll bar between one of the arrows and the scroll box will move you one screen in the direction of the nearest
arrow.

The Undo command

Just about anything you do in Excel can be undone by choosing Undo under the Edit menu.  This includes
entering data, sorting, copying, pasting, and so on.  The important thing to remember, though, is that Undo
will only undo the very last thing you did.  For instance, if you just sorted your data, and you decide after
typing in a column label that you didn't want to sort the data yet, choosing Undo will result in removing the
column label, not undoing the sort.

Undo will not work on most commands under the File menu, like Save or New....  It will also not undo
cursor movements, like scrolling around in the document or clicking in different cells.

Resizing columns

To make columns narrower or wider, click and drag on the small vertical lines separating the column labels at
the top of the sheet.  Double-clicking on these lines will automatically adjust the size of the column to fit the
widest entry in that column.

Shifting between windows

If you have more than one worksheet open, you may move between them in one of two ways:
1.  Under the Window menu option, choose the appropriate window name in the list of open windows.
2.  If part of another window is visible, you may move to that window by clicking on the visible portion.

Using the clipboard to move data to another program

To "export" data in your Excel worksheet to another program, highlight the data you want to export, then
choose Copy from the Edit menu.  The data is now stored temporarily in the Clipboard.  The data will stay
in the Clipboard when you move to another application (see the "Windows Frequently Asked Questions"
handout for more details).  In the other application, click on the location you want the data to go into, and
choose Paste under the Edit menu.  Note that you may also use this procedure to copy and paste data and
functions to other locations within Excel.

Moving cells to another location

To move the contents of a cell or group of cells, first highlight the cell(s) by clicking in a single cell or by
clicking in a corner of a group of cells and dragging to the diagonally opposite corner.  Then position the
arrow at one edge of the selected portion.  Now, press the mouse button and drag the selected portion to the
desired new location.  A heavy line will show where the cell(s) will be put when you release the button.

NOTE:  Any functions (see below) that refer to other cells will still continue to refer to the appropriate cells
after the move.  This is an important difference from using Copy and Paste to move the contents of cells (see
"Copying functions to another location" below).  When using Copy and Paste, it will not generally be true that
cell references will continue to refer to the same cells after pasting into the new location.

Creating new files

To create a new spreadsheet, choose New... from the File menu.  Be sure "Worksheet" is selected in the
box that comes up, then choose OK.
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Saving files

To save a new worksheet, choose Save under the File menu.  A box will come up giving you options for
naming the worksheet and navigating through your various folders and drives to specify where you want to
save the worksheet (see the handout "Window Frequently Asked Questions" for more details).  If you are
saving updates to an existing file, choosing Save will save the file to the same location as before.

To rename your worksheet, use the Save as... menu option.  When you do this, any changes you made
since the last time you saved will be included in the new file.  The old file will still exist, but it will not contain
any changes you made since the last save.

IMPORTANT!  It is a good idea to get in the habit of saving your files often.

Closing windows

To close a window, click in the small box  (marked with an ‘X’) in the upper right-hand corner of the
worksheet.  If you have made any changes since the last time you saved your worksheet, Excel will give you
the option of saving now.  Note that even if you make all your windows go away by this method, it does not
mean that you have quit Excel (see "Quitting Excel" below).

Quitting Excel

To quit Excel, choose Quit under the File menu.  If you have any worksheets open that you've made
changes to but have not saved, Excel will ask you if you want to save each one.

How do I enter data?

The computer programs we use in this course automatically format the data and copy it to the clipboard.  To paste
the data into Excel, choose Paste under the Edit menu.

To enter data or labels by hand, position the cursor over the cell where you want the data or label to appear, click
the mouse button, and start typing.  You'll notice that what you type appears in two places--one, in the cell itself,
and another in a box near the top of the screen.  If you need to edit what you type, you can do this by positioning
the cursor over the text or numbers in this box and editing as you would with a word processor.

How do I insert rows or columns?

The process of inserting cells will behave in slightly different ways depending on what you want:

Inserting entire rows or columns.

This operation will insert a row or column extending to the entire length or width of your spreadsheet.  First,
select the entire row or column by clicking once on the number (for rows) or letter (for columns) that appear
on the extreme left or top of the spreadsheet.  The row or column should be highlighted.  Now, choose
Cells... from the Insert menu, and the new row or column will appear.

NOTE:  Be sure this is what you want.  If there are cells off-screen that you want to keep together, this
command could insert a space between them.

Inserting individual cells or groups of cells:

If you simply want to add a few cells, click on where you want the new cell to appear and choose Cells...
from the Insert menu.  A box will come up asking if you want to shift the other cells to the right or shift
them down.  Choose the one you want, then click OK.
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NOTE:  Again, be sure this is what you want.  When the other cells are shifted right or down, you may be
shifting cells that you want to keep together.

How do I delete rows or columns?

Deleting rows and columns uses almost the same commands and is subject to the same warnings as inserting rows
and columns.  The Delete... command is also found under the Edit menu.  Again, a box will come up asking
if you want to shift the other cells to the right or shift them down.  Choose the one you want, then click OK (see
also "How do I clear cells?" below).

How do I clear cells?

Sometimes you may simply want to remove text or formulas from a cell without actually removing the cell (see the
difference?).  To do this, highlight the cell or cells you want to clear, and then choose Clear... under the Edit
menu.  A box will come up which gives you several options--choose "All", then OK.  (In this class, we will
ignore the added flexibility the other options provide.)

Sorting

Sometimes data is not grouped in a way that makes it convenient to graph or to analyze.  For instance, suppose in
the example below you wanted to compare the data for group 1 with the data from group 2:

We can't easily compare the two groups when the data are grouped this way, because the two groups are mixed in
together.  What we need to do is arrange the data so that all the group 1 data is together, and all the group 2 data is
together.  To sort according to group, do the following:

1.  Select the cells that you want to sort.  That is, click in the upper left-hand cell of the area you want to sort and
drag the cursor down to the lower right-hand cell:

Click here, and drag....

...down 
to here
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NOTE:  Don't select the column labels (line length, etc. in the example above), because if you do they will be
sorted along with everything else and might end up somewhere you don't expect.

NOTE:  Be sure to select all the cells that should remain associated with your data.  In the example above, you
would want to include the cells under "trial no." and "line length" in your sorting, because otherwise those
cells would not be sorted, and would no longer refer to the data in the other columns which were sorted.

2.  Choose Sort... under the Data menu option.  You will see a box pop up like the one below:

3.  Be sure "Header row" is selected in the "My list has" box.

4.  Select the appropriate column to sort by.  We will call these columns sort “keys”.  These tell Excel how to
group the data.  The 1st key (top) specifies the largest grouping, and the 2nd (middle) and 3rd (bottom) keys
specify smaller groupings within the largest groups.  For example, we might want to have group 1's data arranged
together, followed by group 2's data.  Within each of those groups, we might want to see the line length 40 data
grouped together, then the line length 60 data.  So, "group" would be the first key, and "line length" the second
key.

Excel makes a first guess about what should be the first key--it fills in the topmost "Sort By" box with the text that
appears in the first selected column.  This first guess will always be the text that appears above the upper left-hand
cell in the area you selected for sorting (as long as “Header row” is selected in the “My list has” box).  Often, this
guess will not be what we want.  To specify the sorting keys, click on the down arrow that appears on the right
side of the “Sort by” box.  This will bring up a pull down menu from which you can select another column.

NOTE:  If “No header row” is selected from the “My list has” box, then the text that appears in the “Sort by” box
will be the name of the left most column of the selected cells, i.e., “Column A”.
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5.  Be sure the Ascending/Descending buttons are selected the way you want.  "Ascending" means that larger
values will be sorted to come after smaller ones.  For example, all the ones will be grouped together, then all the
twos.  If you are sorting by letters or words, choosing "Ascending" will result in alphabetical sorting.  Clicking
on "Descending" would reverse this order (twos first, then ones).

6.  Click OK to conduct the sort.  The result of sorting our example is shown in the next figure.  Note that all the
group 1 data is together, then all the group 2 data.  Within those groups, the line length 40 data, is grouped
together, then the line length 60 data.

Warning:

If you have formulas in other cells that depend on having your data in a particular order (the averages in the
example above), these formulas will continue to slavishly refer to the cells they were originally intended to
refer to, even though the values in them have now been changed due to sorting.  You can see that this has
happened in the example above--the averages are no longer appropriate.

What do I do if the sort doesn't do what I want?

Sorting can radically change the look of your data, and this can be especially disconcerting if the sort doesn't
go the way you expect.  To revert back to the way your data looked before the sort, choose Undo under the
Edit menu.

NOTE: this will only work if you have not done anything other than scrolling around in your spreadsheet.
So, be very careful immediately after sorting.  Check to be sure the sort went as you planned before
performing any other operations.

Using Functions

Introduction

Functions make Excel a very versatile and powerful spreadsheet program.  They allow the user to perform
many sophisticated operations and statistical tests.  We'll only use functions to perform some simple
mathematical operations on our data.  For example, suppose you want to compute the mean of a column of
data.
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ordinary text or numbers by having an equals sign (=) in front of them.  So, before typing in any functions, first
type the equals sign.  Now type in the rest of the formula:   =AVERAGE()   Position the cursor between the
parentheses.  If you know the addresses of the cells you want to average over, you can type those between the
parentheses.  Type the address of the first cell in the column, followed by a colon (:), followed by the address of
the last cell:  C2:C9, in our example.  Or you can click and drag to select those cells the way we did before.
Finally, to compute the mean, hit the "enter" key.

Ways to enter the addresses of cells:

Manually    .  If you know the address of a specific cell, you can type it into the formula bar at the appropriate
place.  This method can be cumbersome if you need to enter the address of many cells.

Single cells   .  The first time you click on another cell after you type the equals sign, Excel will insert the
address of that cell.  If you were to hit return or enter at this point, the value of the other cell will appear in
the new cell.

RULE OF THUMB:  If you're simply listing the cells or arrays of cells that you want a formula to include
in its computations, each member of the list should be separated by a    comma   , not a plus sign.  Thus,
=AVERAGE(c2,c3,c4) will correctly compute the mean of cells c2, c3, and c4, but
=AVERAGE(c2+c3+c4) will simply add those cells together.

Continuous range of cells (an Array)   .  To enter the addresses of a block of several columns and rows of
cells, click in one corner of the block and drag to the diagonally opposite corner.  You'll note that the
address in the formula bar will include the address of the first corner, followed by a colon and then
address of the diagonally opposite corner (C2:E4).  Again, if you already know these addresses, you
could type them in yourself.

Commonly-used functions:

mean: =AVERAGE(c2:c4) Computes the mean of cells c2, c3, and c4.
OR: =AVERAGE(c2,c3,c4)       NOTE    : =AVERAGE(c2+c3+c4) won't work properly

standard deviation:  =STDEV(c2:c9)
square root:  =SQRT(c2)
standard error:  = STDEV(c2:c9)/SQRT(8)  Note that you'll want to replace the number after the

SQRT with the number of cells you're including in the standard deviation.
sum:  =SUM(c2:c9)

OR:  =c2+c3+c4 (etc.)  Each cell that you click on will be included in the sum.
subtraction:  = c2-c3 (subtracts cell c3 from cell c2)
multiplication:  =c2*5  (multiplies cell C2 by 5)

=c2*c9 (multiplies cell C2 by cell C9)
division: =c2/5 (divides cell C2 by 5)

=c2/c9 (divides cell c2 by cell c9)

Function help

To obtain a more in-depth explanation of any Excel function, choose Function... under the Insert menu
option.  Choose the help button in the lower left corner of the window that appears. This will bring up Excel’s
Help Wizard.

Fitting a line to data

You can use the Excel function =LINEST to calculate the best-fitting straight line through a set of points.  The
best way to conceptualize this is to think how the points might look if they were plotted on a graph.  To use
the linest function, you need two columns of data:  one will contain the "x" values (horizontal axis) on the
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graph, and the other column will contain the "y" values (vertical axis)--the "y" values typically will be the
values of the dependent variable (the measurements from an experiment).

To obtain the value of the slope of the best fitting straight line through the data in the "y" column, type:
=LINEST(y-values,x-values).  (don't type the period)  You should replace "y-values" and "x-values" with the
addresses of those two columns of data.  When you press the enter key, the slope will appear in the cell.

To obtain the value of the intercept, type:  =INDEX(LINEST(y-values,x-values),2)

To fit a line that goes through zero on the y-axis (i.e., to force the y-intercept to be zero), type:
=LINEST(y-values,x-values,FALSE).  (without the period)

Filling right, filling down

Once you've entered a function, it's often the case that you want the same function to apply to other adjacent
columns or rows of data.  For instance:

Want to calculate the mean
of each of these columns

Click on this
cell, and drag...

...over to this one.
Then choose "Fill 
Right" under the Edit 
menu

To fill in a function across a row of cells, first click on the cell that contains the function you want to fill into
other cells.  Then drag the cursor to highlight the other cells you want to contain that function.  Now, choose
Fill then Right under the Edit menu.  If you now click in any of the cells you highlighted, you'll find that
the function appears in the formula bar, and the value calculated by the function appears in the cell itself.  The
cell addresses in each of these functions, furthermore, have been updated so that they are appropriate for the
columns above them.  You may also highlight a column of cells and fill in functions down  the column by
choosing Fill then Down menu.

Copying Functions to another location

Another shortcut for copying a function to another location is to Copy the functions contained in a cell or
group of cells and Paste them into another group of cells.  To do this, first highlight the cells that contain the
functions you want to copy, and then choose Copy under the Edit menu.  Highlight the new cells you want
to contain the functions, and choose Paste under the Edit menu.

References to cell addresses that are contained in the functions in the new locations will refer to the cells
relative to the new location.  Thus, if you paste in the "average" function from another location, and that
average was over a column of 8 cells just above it, the function at the new location will compute the mean of
the 8 cells just above the new location.
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Paste Special.

Sometimes you'll want to move the values computed by a function without moving the function itself.  For
example, suppose you have just computed the mean of a column of data using the "Average" function.  If you
were to select the cell containing the function and choose Copy under the Edit menu and then Paste into
another cell, the function is what will get pasted (e.g., "=AVERAGE(c4:c9)"), not the numerical value computed
by the function (e.g., "47.5").  To copy and paste the numerical result of a function, select the cell(s) containing
the values you want to move.  Copy them by choosing Copy under the Edit menu.  Click in the cell you want
the values to go into, then choose Paste Special... under the Edit menu.  Click on the button next to
"Values" in the box that comes up, then choose OK.


